cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot send SMS Texts after porting to Smarty

NigelW
SMARTY Pioneer
SMARTY Pioneer

Hi

posting this as even though the problem has now resolved itself I don’t know what fixed it. Also, I read this article https://help.smarty.co.uk/en/articles/1170797-problems-with-sending-text-messages# and it did not make complete sense or did not work. 

The problem, after porting our existing numbers into Smarty we found that text messages no longer worked on iPhone. 

I think that the following steps fixed the problem. 

Go into Settings > iMessage

Remove any incorrect numbers

Disable iMessage

Switch off and switch on the phone

Re-enable iMessage

Wait for your new number and any email addresses to be added automatically as iMessage reactivates.

As mentioned, the above help article did not help. Under iPhone, step 1 is too ambiguous. What app are we using? The keypad could perhaps be the phone or the iMessage?

I tried dialling *#*#4636#*#*
the Number/command was not recognised. 

 

 

3 REPLIES 3

MSF
SMARTY Genius
SMARTY Genius

@NigelW  I agree that removing old numbers in Settings probably did the trick. It does seem that iPhones 'remember' the original number on the sim and have to be coaxed into using the ported number.

This is a common problem. Unfortunately, I don't think the the article you mentioned was relevant in this case.

NigelW
SMARTY Pioneer
SMARTY Pioneer

Anyhow. I solved the problem or it sorted itself out. Maybe I just had to wait for a few hours. 

Chalkychap
SMARTY Major Player
SMARTY Major Player

The process given in the "problems-with-sending-text-messages" article might work with an older version of iOS, @NigelW.

It seems more recent versions of iOS now conceal the network provider's SMS service centre number.